5 RIP version 1

5.0 Routing Information Protocol

5.0.1 Chapter Introduction

Page 1:
Over the years, routing protocols have evolved to meet the increasing demands of complex networks. The first protocol used was Routing Information Protocol (RIP). RIP still enjoys popularity because of its simplicity and widespread support.

Understanding RIP is important to your networking studies for two reasons. First, RIP is still in use today. You may encounter a network implementation that is large enough to need a routing protocol, yet simple enough to use RIP effectively. Second, familiarity with many of the fundamental concepts of RIP will help you to compare RIP with other protocols. Understanding how RIP operates and its implementation will make learning other routing protocols easier.

This chapter covers the details of the first version of RIP, including a bit of history, RIPv1 characteristics, operation, configuration, verification, and troubleshooting. Throughout the chapter, you can use Packet Tracer activities to practice what you learn. At the end of the chapter, three hands-on labs and a Packet Tracer Skills Integration Challenge activity are provided to help you integrate RIPv1 into your growing set of networking knowledge and skills.


5.0.1 - Chapter Introduction
The diagram depicts the dynamic routing protocols covered in this course. These include RIP, RIP v2, EIGRP, and OSPF v2. The RIP protocol covered in this chapter is highlighted. In this chapter, you will learn to:
- Describe the functions, characteristics, and operation of the RIP v1 protocol.
- Configure a device for using RIP v1.
- Verify proper RIP v1 operation.
- Describe how RIP v1 performs automatic summarization.
- Configure, verify, and troubleshoot default routes propagated in a routed network implementing RIP v1.


5.1 RIPv1: Distance Vector, Classful Routing Protocol

5.1.1 Background and Perspective

Page 1:
RIP Historical Impact

RIP is the oldest of the distance vector routing protocols. Although RIP lacks the sophistication of more advanced routing protocols, its simplicity and continued widespread use is a testament to its longevity. RIP is not a protocol "on the way out." In fact, an IPv6 form of RIP called RIPng (next generation) is now available.

Click the dates in the figure to compare RIP and network protocol development over time.

RIP evolved from an earlier protocol developed at Xerox, called Gateway Information Protocol (GWINFO). With the development of Xerox Network System (XNS), GWINFO evolved into RIP. It later gained popularity because it was implemented in the Berkeley Software Distribution (BSD) as a daemon named routed (pronounced "route-dee", not "rout-ed"). Various other vendors made their own, slightly different implementations of RIP. Recognizing the need for standardization of the protocol, Charles Hedrick wrote RFC 1058 in 1988, in which he documented the existing protocol and specified some improvements. Since then, RIP has been improved with RIPv2 in 1994 and with RIPng in 1997.

Note: The first version of RIP is often called RIPv1 to distinguish it from RIPv2. However, both versions share many of the same features. When discussing features common to both versions, we will refer to RIP. When discussing features unique to each version, we will use RIPv1 and RIPv2. RIPv2 is discussed in a later chapter.

Links

"RFC 1058: Routing Information Protocol," http://www.ietf.org/rfc/rfc1058.txt


5.1.1 - Background and Perspective
The diagram depicts an overview of RIP's historical impact.

- Early 1970's: TCP/IP Early Development.
- Mid 1970's: Xerox PARC Universal Protocol (PUP) and Gateway Information Protocol (GW INFO).
- Late 1970's: Xerox Network System (XNS) and Routing Information Protocol
- Early 1980's: TCP/IP Standardized RFC's 791 and 793 and Berkeley Software Distribution (UNIX BSD 4.2).
- 1988: RFC 1058: RIP
- 1994: RFC 1723: RIP v2
- 1997: RFC 2080: RIP n g


5.1.2 RIPv1 Characteristics and Message Format

Page 1:
RIP Characteristics

As discussed in Chapter 4, "Distance Vector Routing Protocols," RIP has the following key characteristics:
  • RIP is a distance vector routing protocol.
  • RIP uses hop count as its only metric for path selection.
  • Advertised routes with hop counts greater than 15 are unreachable.
  • Messages are broadcast every 30 seconds.
Roll over the fields in the Encapsulated RIPv1 Message to see the encapsulation process.

The data portion of a RIP message is encapsulated into a UDP segment, with both source and destination port numbers set to 520. The IP header and data link headers add broadcast destination addresses before the message is sent out to all RIP configured interfaces.


5.1.2 - RIP v1 Characteristics and Message Format
The diagram depicts an encapsulated RIP v1 message format.

Data Link Frame Header:
MAC Destination Address - Broadcast: FF-FF-FF-FF-FF-FF
MAC Source Address - Address of sending interface

IP Packet Header:
IP Source Address - Address of sending interface
IP Destination Address - Broadcast: 255.255.255.255
Protocol field - 17 for UDP

UDP Segment Header:
Source Port = 520
Destination Port = 520

RIP Message (504 bytes; Up to 25 routes):
Command: Request (1): Response (2)
Version - 1
Address Family ID - 2 for IP
Routes: Network IP Address
Metric: Hop Count


Page 2:
RIP Message Format: RIP Header

Three fields are specified in the four byte header portion shown in orange in the figure. The Command field specifies the message type, discussed in more detail in the next section. The Version field is set to 1 for RIP version 1. The third field is labeled Must be zero. "Must be zero" fields provide room for future expansion of the protocol.

RIP Message Format: Route Entry

The route entry portion of the message includes three fields with content: Address family identifier (set to 2 for IP unless a router is requesting a full routing table, in which case the field is set to zero), IP address, and Metric. This route entry portion represents one destination route with its associated metric. One RIP update can contain up to 25 route entries. The maximum datagram size is 504 bytes, not including the IP or UDP headers.

Why are there so many fields set to zero?

RIP was developed before IP and was used for other network protocols (like XNS). BSD also had its influence. Initially, the extra space was added with the intention of supporting larger address spaces in the future. As we will see in Chapter 7, RIPv2 has now used most of these empty fields.


5.1.2 - RIP v1 Characteristics and Message Format
The diagram depicts the RIP v1 message format.

- RIP Message (504 bytes; Up to 25 routes):
- Command = 1 or 2
- Version = 1
- Must be zero
- Address family identifier (2 = IP)
- Must be zero
- IP Address (Network Address)
- Must be zero
- Must be zero
- Metric (Hops)
- Multiple Route Entries, up to a maximum of 25

A table contains additional information on the fields in the message:
- Command: 1 for a Request or 2 for a Reply.
- Version: 1 for RIP v1 or 2 for RIP v2.
- Address Family Identifier: 2 for IP unless a Request is for the full routing table, in which case, set to 0.
- IP Address: The address of the destination route, which may be a network, subnet, or host address.
- Metric: Hop count between 1 and 16. Sending router increases the metric before sending out the message.


5.1.3 RIP Operation

Page 1:
RIP Request/Response Process

RIP uses two message types specified in the Command field: Request message and Response message.

Click Play to view the request/response process.

Each RIP-configured interface sends out a request message on startup, requesting that all RIP neighbors send their complete routing tables. A response message is sent back by RIP-enabled neighbors. When the requesting router receives the responses, it evaluates each route entry. If a route entry is new, the receiving router installs the route in the routing table. If the route is already in the table, the existing entry is replaced if the new entry has a better hop count. The startup router then sends a triggered update out all RIP-enabled interfaces containing its own routing table so that RIP neighbors can be informed of any new routes.


5.1.3 - RIP Operation
The animation depicts RIP operation. The animation is based on the following network topology.

Network Topology:
There are three routers, R1, R2, and R3. Router R1 has a LAN attached and is connected to routers R2 and R3 via WAN links. R2 has a LAN attached and is connected to routers R1 and R3 via WAN links. R3 has a LAN attached and is connected to routers R1 and R2 via WAN links.

As the animation progresses, R3 starts the RIP processes by sending a RIP request message to R1 and R2. R1 and R2 send a response message back to R3. R3 sends updates to R1 and R2.


Page 2:
IP Address Classes and Classful Routing

You may recall from previous studies that IP addresses assigned to hosts were initially divided into 3 classes: class A, class B, and class C. Each class was assigned a default subnet mask, as shown in the figure. Knowing the default subnet mask for each class is important to understanding how RIP operates.

RIP is a classful routing protocol. As you may have realized from the previous message format discussion, RIPv1 does not send subnet mask information in the update. Therefore, a router either uses the subnet mask configured on a local interface, or applies the default subnet mask based on the address class. Due to this limitation, RIPv1 networks cannot be discontiguous nor can they implement VLSM.

IP Addressing is discussed further in Chapter 6, "VLSM and CIDR." You can also visit the links below for a review of the classes.

Links

"Internet Protocol," http://www.ietf.org/rfc/rfc791.txt

"IP Addressing and Subnetting for New Users," http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800a67f5.shtml


5.1.3 - RIP Operation
The diagram depicts default subnet masks for address classes and the range of addresses for Classes A, B, and C.

Class A address: First 8 bits identify the network, and the last 24 bits the host. The default subnet mask is 255.0.0.0.

Class B address: First 16 bits identify the network, and the last 16 bits the host. The default subnet mask is 255.255.0.0.

Class C address: First 24 bits identify the network, and the last 8 bits the host. The default subnet mask is 255.255.255.0.

Class A address range: 1.0.0.0 to 126.255.255.255
Class B address range: 128.0.0.0 to 191.255.255.255
Class A address range: 192.0.0.0 to 223.255.255.255


5.1.4 Administrative Distance

Page 1:
As you know from Chapter 3, "Introduction to Dynamic Routing Protocols," administrative distance (AD) is the trustworthiness (or preference) of the route source. RIP has a default administrative distance of 120. When compared to other interior gateway protocols, RIP is the least-preferred routing protocol. IS-IS, OSPF, IGRP, and EIGRP all have lower default AD values.

Remember, you can check the administrative distance using the show ip route or show ip protocols commands.


5.1.4 - Administrative Distance
The diagram depicts the commands used to verify administrative distance (A D). The image is based on the following network topology.

Network Topology:
There are three routers, R1, R2, and R3. Router R1 has a LAN switch attached and is connected to routers R2 and R3 via WAN links. R2 has a LAN switch attached and is connected to routers R1 and R3 via WAN links. R3 has a LAN switch attached and is connected to routers R1 and R2 via WAN links.

Router R1 LAN has a network address of 192.168.1.0/24.
Router R2 LAN has a network address of 192.168.3.0/24.
Router R3 LAN has a network address of 192.168.5.0/24.
Router R1 to R2 WAN link has a network address of 192.168.2.0/24.
Router R1 to R3 WAN link has a network address of 192.168.6.0/24.
Router R2 to R3 WAN link has a network address of 192.168.4.0/24.


In the output from the show i p route command, the RIP A D of 120 is highlighted for the following routes:
R 192.168.1.0/24 [120/1] via 192.168.6.2, 00:00:05, Serial0/0/0
R 192.168.2.0/24 [120/1] via 192.168.6.2, 00:00:05, Serial0/0/0
[120/1] via 192.168.4.2, 00:00:05, Serial0/0/1
R 192.168.3.0/24 [120/1] via 192.168.4.2, 00:00:05, Serial0/0/1

In the output from the show i p protocols command, the RIP A D of 120 is highlighted:
Gateway: 192.168.6.2
Distance: 120
Last Update: 00:00:10

Gateway: 192.168.4.2
Distance: 120
Last Update: 00:00:18


5.2 Basic RIPv1 Configuration

5.2.1 Basic RIPv1 Configuration

Page 1:
The figure shows the three router topology we used in Chapter 2, "Static Routing". Physically, the topology is the same except that we will not need PCs attached to the LANs. Logically, however, the addressing scheme is different. We are using five class C network addresses.

Click Address Table in the figure to see the interface addressing for each router.


5.2.1 - Basic RIP v1 Configuration
The diagram depicts the basic RIP topology for Scenario A used in this chapter.

RIP Network Topology - Scenario A:
There are three routers, R1, R2, and R3. LAN switch S1 is connected to R1 interface FA0/0. R1 interface S0/0/0 is connected to router R2 interface S0/0/0 via a WAN link.

LAN switch S2 is connected to R2 interface FA0/0. R2 interface S0/0/0 is connected to router R1, and R2 interface S0/0/1 is connected to router R3 via WAN links.

LAN switch S3 is connected to R3 interface FA0/0, and R3 interface S0/0/1 is connected to router R2 via a WAN link.

Router R1 LAN network address: 192.168.1.0/24
Router R2 LAN network address: 192.168.3.0/24
Router R3 LAN network address: 192.168.5.0/24
Router R1 to R2 WAN link network address: 192.168.2.0/24
Router R2 to R3 WAN link network address: 192.168.4.0/24

RIP Topology - Scenario A, Router Address Table:
R1 interface: FA0/0
IP Address: 192.168.1.1
Subnet Mask: 255.255.255.0

R1 interface: S0/0/0
IP Address: 192.168.2.1
Subnet Mask: 255.255.255.0

R2 interface: FA0/0
IP Address: 192.168.3.1
Subnet Mask: 255.255.255.0

R2 interface: S0/0/0
IP Address: 192.168.2.2
Subnet Mask: 255.255.255.0

R2 interface: S0/0/1
IP Address: 192.168.4.2
Subnet Mask: 255.255.255.0

R3 interface: FA0/0
IP Address: 192.168.5.1
Subnet Mask: 255.255.255.0

R3 interface: S0/0/1
IP Address: 192.168.4.1
Subnet Mask: 255.255.255.0


Page 2:
Use the Packet Tracer Activity to configure and activate all the interfaces for the RIP Topology: Scenario A. Detailed instructions are provided within the activity.

Click the Packet Tracer icon for more details.


5.2.1 - Basic RIP v1 Configuration
Link to Packet Tracer Exploration: Configure IP Addresses on Router Interfaces

Use the Packet Tracer Activity to configure and activate all the interfaces for the RIP Topology: Scenario A.


5.2.2 Enabling RIP: router rip command

Page 1:
To enable a dynamic routing protocol, enter the global configuration mode and use the router command. As shown in the figure, if you type a space followed by a question mark, a list of all the available routing protocols supported by the IOS displays.

To enter the router configuration mode for RIP, enter router rip at the global configuration prompt. Notice that the prompt changes from a global configuration prompt to the following:

R1(config-router)#

This command does not directly start the RIP process. Instead, it provides access to configure routing protocol settings. No routing updates are sent.

If you need to completely remove the RIP routing process from a device, negate the command with no router rip. This command stops the RIP process and erases all existing RIP configurations.


5.2.2 - Enabling RIP: router rip command
The diagram depicts RIP routing configuration mode and various routing protocol configuration options. The diagram is based on the network topology described in 5.2.1 diagram 1.

By entering global configuration mode and typing the router command followed by a space and question mark, the following options are displayed:

R1(config)#router ?

BGP Border Gateway Protocol (BGP)
EGP Exterior Gateway Protocol (EGP)
EIGRP Enhanced Interior Gateway Protocol (EIGRP)
IGRP Interior Gateway Routing Protocol (IGRP)
I S-I S I S O I S-I S
I S O- IGRP IGRP for O S I networks
Mobile Mobile routes
ODR On Demand Stub Routes
OSPF Open Shortest Path First (OSPF)
RIP Routing Information Protocol (RIP)


5.2.3 Specifying Networks

Page 1:
By entering the RIP router configuration mode, the router is instructed to run RIP. But the router still needs to know which local interfaces it should use for communication with other routers, as well as which locally connected networks it should advertise to those routers. To enable RIP routing for a network, use the network command in the router configuration mode and enter the classful network address for each directly connected network.

Router(config-router)#network directly-connected-classful-network-address

The network command:
  • Enables RIP on all interfaces that belong to a specific network. Associated interfaces will now both send and receive RIP updates.
  • Advertises the specified network in RIP routing updates sent to other routers every 30 seconds.
Note: If you enter a subnet address, the IOS automatically converts it to a classful network address. For example, if you enter the command network 192.168.1.32, the router will convert it to network 192.168.1.0.


5.2.3 - Specifying Networks
The diagram depicts the network command syntax and purpose.

Purpose:
- Enables sending and receiving RIP updates for interfaces that belong to the specified network.
- Advertises the specified network in RIP updates.

Syntax: Router(config-router)#network directly-connected-classful-address


Page 2:
In the figure, the network command is configured on all three routers for the directly connected networks. Notice that only classful networks were entered.

What happens if you enter a subnet address or interface IP address instead of the classful network address when using the network command for RIP configurations?

R3(config)#router rip
R3(config-router)#network 192.168.4.0
R3(config-router)#network 192.168.5.1


In this example, we entered an interface IP address instead of the classful network address. Notice that the IOS does not give an error message. Instead, the IOS corrects the input and enters the classful network address. This is proven with the verification below.

R3#show running-config
!
router rip
network 192.168.4.0
network 192.168.5.0
!



5.2.3 - Specifying Networks
The diagram depicts enabling RIP with the network command for the three routers in the topology. The diagram is based on the network topology described in 5.2.1 diagram 1.

Router R1 configuration commands:
R1(config)#router rip
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0

Router R2 configuration commands:
R1(config)#router rip
R1(config-router)#network 192.168.2.0
R1(config-router)#network 192.168.3.0
R1(config-router)#network 192.168.4.0

Router R3 configuration commands:
R1(config)#router rip
R1(config-router)#network 192.168.4.0
R1(config-router)#network 192.168.5.0


Page 3:
Use the Packet Tracer Activity to practice configuring RIP routing on all three routers in the topology. Detailed instructions are provided within the activity.

Click the Packet Tracer icon for more details.


5.2.3 - Specifying Networks
Link to Packet Tracer Exploration: Configure RIP Routing on a Network

Use the Packet Tracer Activity to practice configuring RIP routing on all three routers in the topology. Detailed instructions are provided in the activity.


5.3 Verification and Troubleshooting

5.3.1 Verifying RIP: show ip route

Page 1:
Powerful Troubleshooting Commands

To verify and troubleshoot routing, first use show ip route and show ip protocols. If you cannot isolate the problem using these two commands, then use debug ip rip to see exactly what is happening. These three commands are discussed in a suggested order that you might use to verify and troubleshoot a routing protocol configuration. Remember, before you configure any routing - whether static or dynamic - make sure all necessary interfaces are "up" and "up" with the show ip interface brief command.

Click R1, R2, and R3 to see the routing tables.

The show ip route command verifies that routes received by RIP neighbors are installed in a routing table. An R in the output indicates RIP routes. Because this command displays the entire routing table, including directly connected and static routes, it is normally the first command used to check for convergence. Routes may not immediately appear when you execute the command because networks take some time to converge. However, once routing is correctly configured on all routers, the show ip route command will reflect that each router has a full routing table, with a route to each network in the topology.

Click the Topology button.

As you can see in the figure, there are five networks in the topology. Each router lists five networks in the routing table; therefore, we can say that all three routers are converged because each router has a route to every network shown in the topology.


5.3.1 - Verifying RIP: show i p route
The diagram depicts verifying RIP convergence with the show i p route command. The diagram is based on the network topology described in 5.2.1 diagram 1.

The output of the show i p route command for R1 is as follows:
R1#show i p route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
output omitted

Gateway of last resort is not set

R 192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:02, Serial0/0/0
R 192.168.5.0/24 [120/1] via 192.168.2.2, 00:00:02, Serial0/0/0
C 192.168.1.0/24 is not directly connected, FastEthernet0/0
C 192.168.2.0/24 is not directly connected, Serial0/0/0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00;02, Serial0/0/0

The output of the show i p route command for R2 is as follows:
R2#show i p route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
output omitted

Gateway of last resort is not set.

C 192.168.4.0/24 is not directly connected, Serial0/0/1
R 192.168.5.0/24 [120/1] via 192.168.4.1, 00:00:12, Serial0/0/1
R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:22, Serial0/0/0
C 192.168.2.0/24 is not directly connected, Serial0/0/0
C 192.168.3.0/24 is not directly connected, FastEthernet0/0

The output of the show i p route command for R3 is as follows:
R2#show i p route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
output omitted

Gateway of last resort is not set

C 192.168.4.0/24 is not directly connected, Serial0/0/1
C 192.168.5.0/24 is not directly connected, FastEthernet0/0
R 192.168.1.0/24 [120/1] via 192.168.4.2, 00:00:08, Serial0/0/1
R 192.168.2.0/24 [120/1] via 192.168.4.2, 00:00:08, Serial0/0/1
R 192.168.3.0/24 [120/1] via 192.168.4.2, 00:00:08, Serial0/0/1


Page 2:
Interpreting show ip route Output

Using the information in the figure, let's focus on one RIP route learned by R1 and interpret the output shown in the routing table.

R 192.168.5.0/24 [120/2] via 192.168.2.2, 00:00:23, Serial0/0/0

The listing of routes with an R code is a quick way to verify that RIP is actually running on this router. If RIP is not at least partially configured, you will not see any RIP routes.

Next, the remote network address and subnet mask are listed (192.168.5.0/24).

The AD value (120 for RIP) and the distance to the network (2 hops) is shown in brackets.

The next-hop IP address of the advertising router is listed (R2 at 192.168.2.2) and how many seconds have passed since the last update (00:00:23, in this case).

Finally, the exit interface that this router will use for traffic destined for the remote network is listed (Serial 0/0/0).


5.3.1 - Verifying RIP: show i p route
The diagram depicts interpreting the show i p route output. The diagram is based on the network topology described in 5.3.1 diagram 1.

A routing table entry for R1 is shown as an example and explained below.

R 192.168.5.0/24 [120/2] via 192.168.2.2, 00:00:23, Serial 0/0/0

Output: R
Description: Identifies the source of the route as RIP.

Output: 192.168.5.0
Description: Indicates the address of the remote network.

Output: /24
Description: The subnet mask used for this network.

Output: [120/2]
Description: The administrative distance (120) and the metric (2 hops).

Output: via 192.168.2.2
Description: Specifies the address to the next-hop router (R2) to which to send traffic for the remote network.

Output: 00:00:23
Description: Specifies the amount of the time since the route was updated (here, 23 seconds). Another update is due in 7 seconds.

Output: Serial0/0/0
Description: Specifies the local interface through which the remote network can be reached.


5.3.2 Verifying RIP: show ip protocols

Page 1:
Interpreting show ip protocols Output

If a network is missing from the routing table, check the routing configuration using show ip protocols. The show ip protocols command displays the routing protocol that is currently configured on the router. This output can be used to verify most RIP parameters to confirm that:
  • RIP routing is configured
  • The correct interfaces send and receive RIP updates
  • The router advertises the correct networks
  • RIP neighbors are sending updates
This command is also very useful when verifying the operations of other routing protocols, as we will see later with EIGRP and OSPF.

Click button 1 in the figure.

The first line of output verifies that RIP routing is configured and running on router R2. As we saw in the previous section, "Basic RIPv1Configuration," at least one active interface with an associated network command is needed before RIP routing will start.

Click button 2 in the figure.

These are the timers that show when the next round of updates will be sent out from this router - 23 seconds from now, in the example.

Click button 3 in the figure.

This information relates to filtering updates and redistributing routes, if configured on this router. Filtering and redistribution are both CCNP-level topics.

Click button 4 in the figure.

This block of output contains information about which RIP version is currently configured and which interfaces are participating in RIP updates.

Click button 5 in the figure.

This part of the output shows that router R2 is currently summarizing at the classful network boundary and by default will use up to four equal-cost routes to load balance traffic.

Click button 6 in the figure.

The classful networks configured with the network command are listed next. These are the networks that R2 will include in its RIP updates.

Click button 7 in the figure.

Scroll down to see the remaining output. Here, the RIP neighbors are listed as Routing Information Sources. Gateway is the next-hop IP address of the neighbor that is sending R2 updates. Distance is the AD that R2 uses for updates sent by this neighbor. Last Update is the seconds since the last update was received from this neighbor.


5.3.2 - Verifying RIP: show i p protocols
The diagram depicts interpreting show i p protocols output. The diagram is based on the network topology described in 5.3.1 diagram 1.

Output 1: Routing Protocol is rip.
Explanation of output: Shows which routing processes are enabled.

Output 2: Sending updates every 30 seconds, next due in 23 seconds.
Invalid after 180 seconds, hold down 180, flushed after 240.
Explanation of output: Timers currently in use, including when the next update will be sent out by this router (23 seconds).

Output 3: Outgoing update filter list for all interfaces is not set.
Incoming update filter list for all interfaces is not set.
Redistributing: rip
Explanation of output: CCNP-level topics include:
Filtering which updates this router will send and receive.
Redistributing: rip means that this router is sending and receiving only RIP.

Output 4. Default version control: send version 1, receive any version.
Interface: FastEthernet0/0
Send: 1
Receive: 1 and 2
Interface: Serial0/0/0
Send: 1
Receive: 1 and 2
Interface: Serial0/0/1
Send: 1
Receive: 1 and 2

Explanation of output: Shows which interfaces are currently sending and receiving RIP updates as well as which RIP version.

Output 5:
Automatic network summarization is in effect.
Maximum path: 4

Explanation of output: Automatic summarization means that this router is summarizing to the classful network boundary. Maximum paths specify how many equal-cost routes RIP will use to send traffic to the same destination.

Output 6:
Routing for Networks:
192.168.2.0
192.168.3.0
192.168.4.0

Explanation of output: Routing for networks displays the classful network address configured in RIP router configuration mode.

Output 7:
Routing Information Sources:
Gateway: 192.168.2.1
Distance: 120
Last Update: 00:00:18
Gateway: 192.168.4.1
Distance: 120
Last Update: 00:00:22
Distance: (default is 120)

Explanation of output: Routing Information Sources are the RIP neighbors this router is currently receiving updates from. Includes the next-hop IP address, the A D, and when the last update was received. Last line shows the A D for this router.


5.3.3 Verifying RIP: debug ip rip

Page 1:
Interpreting debug ip rip Output

Most RIP configuration errors involve an incorrect network statement configuration, a missing network statement configuration, or the configuration of discontiguous subnets in a classful environment. As shown in the figure, an effective command used to find issues with RIP updates is the debug ip rip. This command displays RIP routing updates as they are sent and received. Because updates are periodic, you need to wait for the next round of updates before seeing any output.

Click button 1 in the figure.

First we see an update coming in from R1 on interface Serial 0/0/0. Notice that R1 only sends one route to the 192.168.1.0 network. No other routes are sent because doing so would violate the split horizon rule. R1 is not allowed to advertise networks back to R2 that R2 previously sent to R1.

Click button 2 in the figure.

The next update that is received is from R3. Again, because of the split horizon rule, R3 only sends one route - the 192.168.5.0 network.

Click button 3 in the figure.

R2 sends out its own updates. First, R2 builds an update to send out the FastEthernet0/0 interface. The update includes the entire routing table except for network 192.168.3.0, which is attached to FastEthernet0/0.

Click button 4 in the figure.

Next, R2 builds an update to send to R3. Three routes are included. R2 does not advertise the network R2 and R3 share nor does it advertise the 192.168.5.0 network because of split horizon.

Click button 5 in the figure.

Finally, R2 builds an update to send to R1. Three routes are included. R2 does not advertise the network that R2 and R1 share, nor does it advertise the 192.168.1.0 network because of split horizon.

Note: If you waited another 30 seconds, you would see all the debug output shown in the figure repeat because RIP sends out periodic updates every 30 seconds.

Click button 6 in the figure.

To stop monitoring RIP updates on R2, enter the no debug ip rip command or simply undebug all, as shown in figure.

Reviewing this debug output, we can verify that RIP routing is fully operational on R2. But do you see a way that we could optimize RIP routing on R2? Does R2 need to send updates out FastEthernet0/0? We will see in the next topic how we can prevent unnecessary updates.


5.3.3 - Verifying RIP: debug i p rip
The diagram depicts interpreting debug i p rip output The diagram is based on the network topology described in 5.3.1 diagram 1.

R2#debug i p rip
RIP protocol debugging is on
-Interpreting debug i p rip output

Output 1:
RIP: received v1 update from 192.168.2.1 on Serial0/0/0
192.168.1.0 in 1 hop
Explanation of output: R2 receives an update from R1 advertising R1's directly connected LAN.

Output 2:
RIP: received v1 update from 192.168.4.1 on Serial0/0/1
192.168.5.0 in 1 hop
Explanation of output: R2 receives an update from R3 advertising ,R3's directly connected LAN.

Output 3:
RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.3.1)
RIP: build update entries
Network 192.168.1.0 metric 2
Network 192.168.2.0 metric 1
Network 192.168.4.0 metric 1
Network 192.168.5.0 metric 2
Explanation of output: R2 sends an update out FA0/0 to all networks in the routing table except the network attached to FA0/0.

Output 4:
RIP: sending v1 update to 255.255.255.255 via Serial0/0/1 (192.168.4.2)
RIP: build update entries
Network 192.168.1.0 metric 2
Network 192.168.2.0 metric 1
Network 192.168.3.0 metric 1

Explanation of output: R2 sends an update out S0/0/1 to R3. Included in the update are R1's LAN, the WAN between R1 and R2, and R2's LAN.
Note that split horizon is in effect. R2 does not advertise the R3 LAN back to R3.

Output 5:
RIP: sending v1 update to 255.255.255.255 via Serial0/0/0 (192.168.2.2)
RIP: build update entries
Network 192.168.3.0 metric 1
Network 192.168.4.0 metric 1
Network 192.168.5.0 metric 2

Explanation of output: R2 sends an update out S0/0/0 to R1. Included in the update is R3's LAN, the WAN between R2 and R3, and R2's LAN.
Note that split horizon is in effect. R2 does not advertise the R1 LAN back to R1.

Output 6:
R2#undebug all
All possible debugging has been turned off.

Explanation of output: Make sure that you disable debugging with the undebug all command when done.


5.3.4 Passive Interfaces

Page 1:
Unnecessary RIP Updates Impact Network

As you saw in the previous example, R2 is sending updates out FastEthernet0/0 even though no RIP device exists on that LAN. R2 has no way of knowing this and, as a result, sends an update every 30 seconds. Sending out unneeded updates on a LAN impacts the network in three ways:

1. Bandwidth is wasted transporting unnecessary updates. Because RIP updates are broadcast, switches will forward the updates out all ports.

2. All devices on the LAN must process the update up to the Transport layers, where the receiving device will discard the update.

3. Advertising updates on a broadcast network is a security risk. RIP updates can be intercepted with packet sniffing software. Routing updates can be modified and sent back to the router, corrupting the routing table with false metrics that misdirect traffic.

Stopping Unnecessary RIP Updates

You might think you could stop the updates by removing the 192.168.3.0 network from the configuration using the no network 192.168.3.0 command, but then R2 would not advertise this LAN as a route in updates sent to R1 and R3. The correct solution is to use the passive-interface command, which prevents the transmission of routing updates through a router interface but still allows that network to be advertised to other routers. Enter the passive-interface command in router configuration mode.

Router(config-router)#passive-interface interface-type interface-number

This command stops routing updates out the specified interface. However, the network that the specified interface belongs to will still be advertised in routing updates that are sent out other interfaces.

In the figure, R2 is first configured with the passive-interface command to prevent routing updates on FastEthernet0/0 because no RIP neighbors exist on the LAN. The show ip protocols command is then used to verify the passive interface. Notice that the interface is no longer listed under Interface, but under a new section called Passive Interface(s). Also notice that the network 192.168.3.0 is still listed under Routing for Networks, which means that this network is still included as a route entry in RIP updates that are sent to R1 and R3.

All routing protocols support the passive-interface command. You will be expected to use the passive-interface command when appropriate as part of your normal routing configuration.


5.3.4 - Passive Interfaces
The diagram depicts disabling updates with the passive-interface command. The diagram is based on the network topology described in 5.3.1 diagram 1.

After entering the command passive-interface FastEthernet 0/0, the show i p protocols command shows that only the serial interfaces are participating in RIP updates. The following lines of the output are highlighted.

Interface: Serial0/0/0
Send: 1
Receive: 1 2

Interface: Serial0/0/1
Send: 1
Receive: 1 2

Routing for networks 192.168.3.0.

Passive interfaces FastEthernet0/0.

FastEthernet 0/0 is no longer listed under the default version control. However, R2 is still routing for 192.168.3.0 and now lists FastEthernet under passive interfaces.


Page 2:
Use the Packet Tracer Activity to verify RIP routing and stop RIP updates using the passive-interface command. Detailed instructions are provided within the activity.

Click the Packet Tracer icon for more details.


5.3.4 - Passive Interfaces
Link to Packet Tracer Exploration: Configure Passive Interfaces in RIP

Use the Packet Tracer Activity to verify RIP routing and stop RIP updates using the passive-interface command. Detailed instructions are provided in the activity.


5.4 Automatic Summarization

5.4.1 Modified Topology: Scenario B

Page 1:
To aid the discussion of automatic summarization, the RIP topology shown in the figure has been modified with the following changes:

Three classful networks are used:
  • 172.30.0.0/16
  • 192.168.4.0/24
  • 192.168.5.0/24
The 172.30.0.0/16 network is subnetted into three subnets:
  • 172.30.1.0/24
  • 172.30.2.0/24
  • 172.30.3.0/24
The following devices are part of the 172.30.0.0/16 classful network address:
  • All interfaces on R1
  • S0/0/0 and Fa0/0 on R2
The 192.168.4.0/24 network is subnetted as a single subnet 192.168.4.8/30


5.4.1 - Modified Topology: Scenario B
The diagram depicts RIP topology: Scenario B, used with this chapter.

Network Topology:
There are three routers, R1, R2 and R3. LAN switch S1 is connected to R1 interface FA0/0, and R1 interface S0/0/0 is connected to router R2 interface S0/0/0 via a WAN link.

LAN switch S2 is connected to R2 interface FA0/0. R2 interface S0/0/0 is connected to router R1, and R2 interface S0/0/1 is connected to router R3 via WAN links.

LAN switch S3 is connected to R3 interface FA0/0, and R3 interface S0/0/1 is connected to router R2 via a WAN link.

Router Address Table:
R1 interface FA0/0 IP address: 172.30.1.1, subnet mask 255.255.255.0
R1 interface S0/0/0 IP address: 172.30.2.1, subnet mask 255.255.255.0
R2 interface FA0/0 IP address: 172.30.3.1, subnet mask 255.255.255.0
R2 interface S0/0/0 IP address: 172.30.2.2, subnet mask 255.255.255.0
R2 interface S0/0/1 IP address: 192.168.4.9, subnet mask 255.255.255.252
R3 interface FA0/0 IP address: 192.168.5.1, subnet mask 255.255.255.0
R3 interface S0/0/1 IP address: 192.168.4.10, subnet mask 255.255.255.252


Page 2:
Click R1, R2, and R3 to view the configuration details for each router.

Notice that the no shutdown and clock rate commands are not needed because these commands are still configured from Scenario A. However, because new networks were added, the RIP routing process was completely removed with the no router rip command before enabling it again.

Click R1 in the figure.

In the output for R1, notice that both subnets were configured with the network command. This configuration is technically incorrect since RIPv1 sends the classful network address in its updates and not the subnet. Therefore, the IOS changed the configuration to reflect the correct, classful configuration, as can be seen with the show run output.

Click R2 in the figure.

In the output for R2, notice that the subnet 192.168.4.8 was configured with the network command. Again, this configuration is technically incorrect and the IOS changed it to 192.168.4.0 in the running configuration.

Click R3 in the figure.

The routing configuration for R3 is correct. The running configuration matches what was entered in router configuration mode.

Note: On assessment and certification exams, entering a subnet address instead of the classful network address in a network command is considered an incorrect answer.


5.4.1 - Modified Topology: Scenario B
The diagram depicts the commands used to view RIP configuration on routers R1, R2, and R3 for scenario B. The diagram is based on the network topology described in 5.4.1 diagram 1.

R1 configuration:
R1(config)#interface f a 0/0
R1(config-i f)#i p address 172.30.1.1 255.255.255.0
R1(config-i f)#interface S0/0/0
R1(config-i f)#i p address 172.30.2.1 255.255.255.0
R1(config-i f)#no router rip
R1(config)#router rip
R1(config-router)#network 172.30.1.0
R1(config-router)#network 172.30.2.0
R1(config-router)#passive-interface FastEthernet 0/0
R1(config-router)#end

R1#show run
output omitted

router rip
passive-interface FastEthernet0/0
network 172.30.0.0

output omitted

R2 configuration:
R2(config)#interface S0/0/0
R2(config-i f)#i p address 172.30.2.2 255.255.255.0
R2(config-i f)#interface f a 0/0
R2(config-i f)#i p address 172.30.3.1 255.255.255.0
R2(config-i f)#interface S0/0/1
R2(config-i f)#i p address 192.168.4.9 255.255.255.252
R2(config-i f)#no router rip
R2(config)#router rip
R2(config-router)#network 172.30.0.0
R2(config-router)#network 192.168.4.8
R2(config-router)#passive-interface FastEthernet 0/0
R2(config-router)#end

R2#show run
output omitted

router rip
passive-interface FastEthernet0/0
network 172.30.0.0
network 192.168.4.0

output omitted

R3 configuration:
R3(config)#interface f a 0/0
R3(config-i f)#i p address 192.168.5.1 255.255.255.0
R3(config-i f)#interface S0/0/1
R3(config-i f)#i p address 192.168.4.10 255.255.255.252
R3(config-i f)#no router rip
R3(config)#router rip
R3(config-router)#network 192.168.4.0
R3(config-router)#network 192.168.5.0
R3(config-router)#passive-interface FastEthernet 0/0
R3(config-router)#end

R3#show run
output omitted

router rip
passive-interface FastEthernet0/0
network 192.168.4.0
network 192.168.5.0

output omitted


5.4.2 Boundary Routers and Automatic Summarization

Page 1:
As you know, RIP is a classful routing protocol that automatically summarizes classful networks across major network boundaries. In the figure, you can see that R2 has interfaces in more than one major classful network. This makes R2 a boundary router in RIP. Serial 0/0/0 and FastEthernet 0/0 interfaces on R2 are both inside the 172.30.0.0 boundary. The Serial 0/0/1 interface is inside the 192.168.4.0 boundary.

Because boundary routers summarize RIP subnets from one major network to the other, updates for the 172.30.1.0, 172.30.2.0 and 172.30.3.0 networks will automatically be summarized into 172.30.0.0 when sent out R2's Serial 0/0/1 interface.

We will see in the next two sections how boundary routers perform this summarization.


5.4.2 - Boundary Routers and Automatic Summarization
The diagram depicts a RIP boundary router. The diagram is based on the following network topology.

Network Topology:
Same as 5.4.1 diagram 1, except that the R1 and R2 LAN's and WAN link between them are surrounded to indicate that they are all part of the same network. Router R2 is identified as the boundary router between the 172.30.0.0 network and the 192.168.x.x networks (those networks directly connected to R3). Router R2 interfaces FA0/0 and S0/0/0 are within the 172.30.0.0 network, and interface S0/0/1 is outside the 172.30.0.0 network.

R2 has interfaces in more than one major classful network. This makes R2 a boundary router in RIP.


5.4.3 Processing RIP Updates

Page 1:
Rules for Processing RIPv1 Updates

The following two rules govern RIPv1 updates:
  • If a routing update and the interface on which it is received belong to the same major network, the subnet mask of the interface is applied to the network in the routing update.
  • If a routing update and the interface on which it is received belong to different major networks, the classful subnet mask of the network is applied to the network in the routing update.
Example of RIPv1 Processing Updates

In the figure, R2 receives an update from R1 and enters the network in the routing table. How does R2 know that this subnet has a /24 (255.255.255.0) subnet mask? It knows because:
  • R2 received this information on an interface that belongs to the same classful network (172.30.0.0) as that of the incoming 172.30.1.0 update.
  • The IP address for which R2 received the "172.30.1.0 in 1 hops" message was on Serial 0/0/0 with an IP address of 172.30.2.2 and a subnet mask of 255.255.255.0 (/24).
  • R2 uses its own subnet mask on this interface and applies it to this and all other 172.30.0.0 subnets that it receives on this interface - in this case, 172.30.1.0.
  • The 172.30.1.0 /24 subnet was added to the routing table.
Routers running RIPv1 are limited to using the same subnet mask for all subnets with the same classful network.

As you will learn in later chapters, classless routing protocols like RIPv2 allow the same major (classful) network to use different subnet masks on different subnets, better known as Variable Length Subnet Masking (VLSM).


5.4.3 - Processing RIP Updates
The diagram depicts debug i p rip and show i p route output for a RIP boundary router. The diagram is based on the network topology described in 5.4.2 diagram 1.

The following lines are highlighted in the output of the debug i p rip command.
RIP: received v1 update from 172.30.2.1 on Serial0/0/0, 172.30.1.0 in 1 hop.

The following lines are highlighted in the output of the show i p route command.
R 172.30.1.0 [120/1] via 172.30.2.1, 00:00:18, Serial0/0/0


5.4.4 Sending RIP Updates

Page 1:
Using Debug to View Automatic Summarization

When sending an update, boundary router R2 will include the network address and associated metric. If the route entry is for an update sent out a different major network, then the network address in the route entry is summarized to the classful or major network address. This is exactly what R2 does for 192.168.4.0 and 192.168.5.0. It sends these classful networks to R1.

R2 also has routes for the 172.30.1.0/24, 172.30.2.0/24 and 172.30.3.0/24 subnets. In R2's routing update to R3 on Serial0/0/1, R2 only sends a summary of the classful network address of 172.30.0.0.

If the route entry is for an update sent within a major network, the subnet mask of the outbound interface is used to determine the network address to advertise. R2 sends the 172.30.3.0 subnet to R1 using the subnet mask on Serial0/0/0 to determine the subnet address to advertise.

R1 receives the 172.30.3.0 update on Serial0/0/0 interface, which has an interface address of 172.30.2.1/24. Since the routing update and interface both belong to the same major network, R1 applies its /24 mask to the 172.30.3.0 route.

Click R1 and R3 Routing Tables in the figure to compare the routing tables.

Notice that R1 has three routes for the 172.30.0.0 major network, which has been subnetted to /24 or 255.255.255.0. R3 has only one route to the 172.30.0.0 network, and the network has not been subnetted. R3 has the major network in its routing table. However, it would be a mistake to assume that R3 does not have full connectivity. R3 will send any packets destined for the 172.30.1.0/24, 172.30.2.0/24, and 172.30.3.0/24 networks to R2 because all three of those networks belong to 172.30.0.0/16 and are reachable through R2.


5.4.4 - Sending RIP Updates
The diagram depicts using debug and show i p route to view automatic summarization. The diagram is based on the network topology described in 5.4.2 diagram 1.

The following debug output from R2 shows routes sent to R1:
R2#debug i p rip
RIP: build update entries
Network 172.30.3.0 metric 1
Network 192.168.4.0 metric 1
Network 192.168.5.0 metric 2

R1 and R3 routing tables can be used to compare routes for network 172.30.0.0. Router R1 receives three individual 172.30.x.0 routes from R2, but R3 receives a summary route 172.30.0.0/16.
R1#show i p route
172.30.0.0/24 is subnetted, 3 subnets
C 172.30.1.0 is directly connected, FastEthernet0/0
C 172.30.2.0 is directly connected, Serial0/0/0
R 172.30.3.0 [120/1] via 172.30.2.2, 00:00:17, Serial0/0/0

R3#show i p route
R 172.30.0.0/16 [120/1] via 192.168.4.9, 00:00:15, Serial0/0/1


5.4.5 Advantages and Disadvantages of Automatic Summarization

Page 1:
Advantages of Automatic Summarization

As we saw with R2 in the previous figure, RIP automatically summarizes updates between classful networks. Because the 172.30.0.0 update is sent out an interface (Serial 0/0/1) on a different classful network (192.168.4.0), RIP sends out only a single update for the entire classful network instead of one for each of the different subnets. This process is similar to what we did when summarized several static routes into a single static route. Why is automatic summarization an advantage?
  • Smaller routing updates sent and received, which uses less bandwidth for routing updates between R2 and R3.
  • R3 has a single route for the 172.30.0.0/16 network, regardless of how many subnets there are or how it is subnetted. Using a single route results in a faster lookup process in the routing table for R3.


5.4.5 - Advantages and Disadvantages of Automatic Summarization
The diagram depicts advantages to automatic summarization. The diagram is based on the network topology described in 5.4.2 diagram 1.

Output from the show i p route command shows that R3 receives a single summarized route.
R3#show i p route
R 172.30.0.0/16 [120/1] via 192.168.4.9, 00:00:15, Serial0/0/1


Page 2:
Is there a disadvantage to automatic summarization? Yes, when there are discontiguous networks configured in the topology.

Disadvantage of Automatic Summarization

As you can see in the figure, the addressing scheme has been changed. This topology will be used to show a main disadvantage with classful routing protocols like RIPv1 - their lack of support for discontiguous networks.

Classful routing protocols do not include the subnet mask in routing updates. Networks are automatically summarized across major network boundaries since the receiving router in unable to determine the mask of the route. This is because the receiving interface may have a different mask than the subnetted routes.

Notice that R1 and R3 both have subnets from the 172.30.0.0/16 major network, whereas R2 does not. Essentially, R1 and R3 are boundary routers for 172.30.0.0/16 because they are separated by another major network, 209.165.200.0/24. This separation creates a discontiguous network, as two groups of 172.30.0.0/24 subnets are separated by at least one other major network. 172.30.0.0/16 is a discontiguous network.


5.4.5 - Advantages and Disadvantages of Automatic Summarization
The diagram depicts the disadvantage of automatic summarization for classful routing protocols like RIP v1 and their lack of support for discontiguous networks. The diagram is based on the following network topology.

Network Topology:
There are three routers, R1, R2, and R3.
R1 interface FA0/0 is connected to LAN switch S1.
R1 interface FA0/1 is connected to LAN switch S2.
R1 interface S0/0/0 is connected to router R2 via a WAN link.
R2 interface FA0/0 is connected to LAN switch S3.
R2 interface S0/0/0 is connected to router R1 via a WAN link.
R2 interface S0/0/1 is connected to router R3 via a WAN link.
R3 interface FA0/0 is connected to LAN switch S4.
R3 interface FA0/1 is connected to LAN switch S5.
R3 interface S0/0/1 is connected to router R2 via a WAN link.

Router Address Table:
R1 interface FA0/0 IP address is 172.30.1.1 with a subnet mask 255.255.255.0.
R1 interface FA0/1 IP address is 172.30.2.1 with a subnet mask 255.255.255.0.
R1 interface S0/0/0 IP address is 209.165.200.229 with a subnet mask 255.255.255.252.
R2 interface FA0/0 IP address is 10.1.0.1 with a subnet mask 255.255.0.0.
R2 interface S0/0/0 IP address is 209.165.200.230 with a subnet mask 255.255.255.252.
R2 interface S0/0/1 IP address is 209.165.200.233 with a subnet mask 255.255.255.252.
R3 interface FA0/0 IP address is 172.30.100.1 with a subnet mask 255.255.255.0.
R3 interface FA0/1 IP address is 172.30.200.1 with a subnet mask 255.255.255.0.
R3 interface S0/0/1 IP address is 209.165.200.234 with a subnet mask 255.255.255.252.


Page 3:
Discontiguous Topologies do not Converge with RIPv1

The figure shows the RIP configuration for each router based on the topology. The RIPv1 configuration is correct, but it is unable to determine all of the networks in this discontiguous topology. To understand why, remember that a router will only advertise major network addresses out interfaces that do not belong to the advertised route. As a result, R1 will not advertise 172.30.1.0 or 172.30.2.0 to R2 across the 209.165.200.0 network. R3 will not advertise 172.30.100.0 or 172.30.200.0 to R2 across the 209.165.200.0 network. Both routers R1 and R3, however, will advertise the 172.30.0.0 major network address.

What is the result? Without the inclusion of the subnet mask in the routing update, RIPv1 cannot advertise specific routing information that will allow routers to correctly route for the 172.30.0.0/24 subnets.

Click the show ip route buttons for R1, R2, and R3 in the figure and review the routes.
  • R1 does not have any routes to the LANs attached to R3.
  • R3 does not have any routes to the LANs attached to R1.
  • R2 has two equal-cost paths to the 172.30.0.0 network.
  • R2 will load balance traffic destined for any subnet of 172.30.0.0. This means that R1 will get half of the traffic and R3 will get the other half of the traffic whether or not the destination of the traffic is for one of their LANs.
In Chapter 7, "RIPv2," you will see a version of this topology. It will be used to show the difference between classful and classless routing.


5.4.5 - Advantages and Disadvantages of Automatic Summarization
The diagram depicts the fact that discontiguous topologies do not converge with RIP v1. The diagram is based on the network topology described in 5.4.5 diagram 2.

The following commands are used to configure RIP with the new discontiguous network address.

R1(config)#router rip
R1(config-router)#network 172.30.0.0
R1(config-route)#network 209.165.200.0

R2(config)#router rip
R2(config-router)#network 10.0.0.0
R2(config-router)#network 209.165.200.0

R3(config)#router rip
R3(config-router)#network 172.30.0.0
R3(config-router)#network 209.165.200.0

The show i p route output for R1, R2, and R3 demonstrates the following.
R1 does not have any routes to the LAN's attached to R3.
R3 does not have any routes to the LAN's attached to R1.
R2 has two equal-cost paths to the 172.30.0.0 network.
R2 will load balance traffic destined for any subnet of 172.30.0.0. This means that R1 will get half of the traffic, and R3 will get the other half of the traffic whether the destination of the traffic is for one of their LAN's or not.


Page 4:
Use the Packet Tracer Activity to implement the Scenario B addressing scheme and explore the advantages and disadvantages of automatic summarization. Detailed instructions are provided within the activity.

Click the Packet Tracer icon for more details.


5.4.5 - Advantages and Disadvantages of Automatic Summarization
Link to Packet Tracer Exploration: Automatic Route Summarization in RIP

Use the Packet Tracer Activity to implement the Scenario B addressing scheme and explore the advantages and disadvantages of automatic summarization.


5.5 Default Route and RIPv1

5.5.1 Modified Topology: Scenario C

Page 1:
Adding Internet Access to the Topology

RIP was the first dynamic routing protocol and was used extensively in early implementations between customers and ISPs, as well as between different ISPs. But in today's networks, customers do not necessarily have to exchange routing updates with their ISP. Customer routers that connect to an ISP do not need a listing for every route on the Internet. Instead, these routers have a default route that sends all traffic to the ISP router when the customer router does not have a route to a destination. The ISP configures a static route pointing to the customer router for addresses inside the customer's network.

In scenario C, R3 is the service provider with access to the Internet, as signified by the cloud. R3 and R2 do not exchange RIP updates. Instead, R2 uses a default route to reach the R3 LAN and all other destinations that are not listed in its routing table. R3 uses a summary static route to reach the subnets 172.30.1.0, 172.30.2.0, and 172.30.3.0.

To prepare the topology, we can leave the addressing in place; it is the same as was used in Scenario B. However, we also need to complete the following steps:

Click RIP configuration in the figure.

1. Disable RIP routing for network 192.168.4.0 on R2.

2. Configure R2 with a static default route to send default traffic to R3.

3. Completely disable RIP routing on R3.

4. Configure R3 with a static route to the 172.30.0.0 subnets.

Click the show ip route tab in the figure for the corresponding router to see the output.


5.5.1 - Modified Topology: Scenario C
The diagram depicts adding Internet access to the topology. The diagram is based on the following network topology.

Network Topology:
Same as 5.4.2 diagram 1, except in this scenario, R3 is the service provider with access to the Internet, as signified by a cloud. R3 and R2 do not exchange RIP updates. Instead, R2 uses a default route to reach the R3 LAN and all other destinations that are not listed in its routing table. R3 uses a summary static route to reach the subnets 172.30.1.0, 172.30.2.0, and 172.30.3.0.

RIP configuration explanation and output:
- Disable RIP routing on R2 for the 192.168.4.0 network only.
- Configure R2 with a default route pointing to R3.

R2(config)#router rip
R2(config-router)#no network 192.168.4.0
R2(config-router)#exit
R2(config)#i p route 0.0.0.0 0.0.0.0 serial 0/0/1

- Completely disable RIP routing on R3.
- Configure R3 with a static route pointing to R2.
R3(config)#no router rip
R3(config)#i p route 172.30.0.0 255.255.252.0 serial 0/0/1

R1 show i p route output:
Gateway of last resort is not set

172.30.0.0/24 is subnetted, 3 subnets
C 172.30.1.0 is directly connected, FastEthernet0/0
C 172.30.2.0 is directly connected, Serial0/0/0
R 172.30.3.0 [120/1] via 712.30.2.2, 00:00:05, Serial0/0/0

R2 show i p route:
Gateway of last resort is 0.0.0.0 to network 0.0.0.0

172.30.0.0/24 is subnetted, 3 subnets
R 172.30.1.0 [120/1] via 172.30.2.1, 00:00:03, Serial0/0/0
C 172.30.2.0 is directly connected, Serial0/0/0
C 172.30.3.0 is directly connected, FastEthernet0/0
192.168.4.0/30 is subnetted, 1 subnets
C 192.168.4.8 is directly connected, Serial0/0/1
S* 0.0.0.0/0 is directly connected, Serial0/0/1

R3 show i p route:
Gateway of last resort is not set

172.30.0.0/22 is subnetted, 1 subnets
S 172.30.0.0 is directly connected, Serial0/0/1
192.168.4.0/30 is subnetted, 1 subnets
C 192.168.4.8 is directly connected, Serial0/0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0


5.5.2 Propagating the Default Route in RIPv1

Page 1:
To provide Internet connectivity to all other networks in the RIP routing domain, the default static route needs to be advertised to all other routers that use the dynamic routing protocol. You could configure a static default route on R1 pointing to R2, but this technique is not scalable. With every router added to the RIP routing domain, you would have to configure another static default route. Why not let the routing protocol do the work for you?

In many routing protocols, including RIP, you can use the default-information originate command in router configuration mode to specify that this router is to originate default information, by propagating the static default route in RIP updates. In the figure, R2 has been configured with the default-information originate command. Notice from the debug ip rip output that it is now sending a "quad-zero" static default route to R1.

Click show ip route in the figure.

In the routing table for R1, you can see that there is a candidate default route, as denoted by the R* code. The static default route on R2 has been propagated to R1 in a RIP update. R1 has connectivity to the LAN on R3 and any destination on the Internet.


5.5.2 - Propagating the Default Route in RIP v1
The diagram depicts propagating a default route with the default-information originate command. The diagram is based on the network topology described in 5.5.1 diagram 1.

Router R2 rip configuration:
R2(config)#router rip
R2(config)#default-information originate

The debug output shows highlighted output:
subnet 0.0.0.0 metric 1

R2 is now sending a "quad-zero" route to R1.

R1 show i p route:
Gateway of last resort is 172.30.2.2 to network 0.0.0.0
R* 0.0.0.0/0 [120/1] via 172.30.2.2, 00:00:16, Serial0/0/0

R1 has a gateway of last resort, a candidate default route.


Page 2:
Use the Packet Tracer Activity to implement Scenario C with static and default routing and configure R2 to propagate a default route. Detailed instructions are provided within the activity.

Click the Packet Tracer icon for more details.


5.5.2 - Propagating the Default Route in RIP v1
Link to Packet Tracer Exploration: Propagating the Default Route in RIP

Use the Packet Tracer Activity to implement Scenario C with static and default routing and configure R2 to propagate a default route. Detailed instructions are provided in the activity.


5.6 RIPv1 Configuration Labs

5.6.1 Basic RIP Configuration

Page 1:
In this lab, you will work through the configuration and verification commands discussed in this chapter using the same three scenarios. You will configure RIP routing, verify your configurations, investigate the problem with discontiguous networks, observe automatic summarization, and configure and propagate a default route.

Click the lab icon for more details.


5.6.1 - Basic RIP Configuration
Link to Hands-on Lab: Basic RIP Configuration

In this lab, you work through the configuration and verification commands discussed in this chapter using the same three scenarios. You configure RIP routing, verify your configurations, investigate the problem with discontiguous networks, observe automatic summarization, and configure and propagate a default route.


Page 2:
Use Packet Tracer Activity 5.6.1 to repeat a simulation of Lab 5.6.1. Remember, however, that Packet Tracer is not a substitute for a hands-on lab experience with real equipment.

A summary of the instructions is provided within the activity. Use the Lab PDF for more details.

Clicking the Packet Tracer icon will launch Scenario A. All scenarios for this simulation of the hands-on lab can be launched from the links below.

Scenario A

Scenario B

Scenario C


5.6.1 - Basic RIP Configuration
Link to Packet Tracer Exploration: Basic RIP Configuration
Use Packet Tracer Activity 5.6.1 to repeat a simulation of Lab 5.6.1. Three Packet Tracer Activities are included for each scenario.


5.6.2 Challenge RIP Configuration

Page 1:
In this lab activity, you will be given a network address that must be subnetted to complete the addressing of the network shown in the Topology Diagram. A combination of RIPv1 and static routing will be required so that hosts on networks that are not directly connected will be able to communicate with each other.

Click the lab icon for more details.


5.6.2 - Challenge RIP Configuration
Link to Hands-on Lab: Challenge RIP Configuration

In this lab activity, you are given a network address that must be subnetted to complete the addressing of the network shown in the Topology Diagram. A combination of RIP v1 and static routing is required so that the hosts on the networks that are not directly connected can communicate with each other.


Page 2:
Use Packet Tracer Activity 5.6.2 to repeat a simulation of Lab 5.6.2. Remember, however, that Packet Tracer is not a substitute for a hands-on lab experience with real equipment.

A summary of the instructions is provided within the activity. Use the Lab PDF for more details.

Click the Packet Tracer icon for more details.


5.6.2 - Challenge RIP Configuration
Link to Packet Tracer Exploration: Challenge RIP Configuration

Use Packet Tracer Activity 5.6.2 to repeat a simulation of Lab 5.6.2.


5.6.3 RIP Troubleshooting

Page 1:
In this lab, you will begin by loading configuration scripts on each of the routers. These scripts contain errors that will prevent end-to-end communication across the network. You will need to troubleshoot each router to determine the configuration errors, and then use the appropriate commands to correct the configurations. When you have corrected all of the configuration errors, all of the hosts on the network should be able to communicate with each other.

Click the lab icon for more details.


5.6.3 - RIP Troubleshooting
Link to Hands-on Lab: RIP Troubleshooting

In this lab, you begin by loading configuration scripts on each of the routers. These scripts contain errors that prevent end-to-end communication across the network. You need to troubleshoot each router to determine the configuration errors, and then use the appropriate commands to correct the configurations. When you have corrected all the configuration errors, all hosts on the network should be able to communicate with each other.


Page 2:
Use Packet Tracer Activity 5.6.3 to repeat a simulation of Lab 5.6.3. Remember, however, that Packet Tracer is not a substitute for a hands-on lab experience with real equipment.

A summary of the instructions is provided within the activity. Use the Lab PDF for more details.

Click the Packet Tracer icon for more details.


5.6.3 - RIP Troubleshooting
Link to Packet Tracer Exploration: RIP Troubleshooting

Use Packet Tracer Activity 5.6.3 to repeat a simulation of Lab 5.6.3.


5.7 Summary

5.7.1 Summary and Review

Page 1:
Summary

RIP (version 1) is a classful, distance vector routing protocol. RIPv1 was one of the first routing protocols developed for routing IP packets. RIP uses hop count for its metric, with a metric of 16 hops meaning that route is unreachable. As a result, RIP can only be used in networks where there are no more than fifteen routers between any two networks.

RIP messages are encapsulated in a UDP segment, with source and destination ports of 520. RIP routers send their complete routing tables to their neighbors every 30 seconds except for those routes which are covered by the split horizon rule.

RIP is enabled by using the router rip command at the global configuration prompt. The network command is used to specify which interfaces on the router will be enabled for RIP along with the classful network address for each directly connected network. The network command enables the interface to send and receive RIP updates and also advertises that network in RIP updates to other routers.

The debug ip rip command can be used to view the RIP updates that are sent and received by the router. To prevent RIP updates from being sent out an interface, such on a LAN where there are no other routers, the passive-interface command is used.

RIP entries are displayed in the routing table with the source code of R and have an administrative distance of 120. Default routes are propagated in RIP by configuring a static default route and using the default-information originate command in RIP.

RIPv1 automatically summarizes subnets to their classful address when sending an update out an interface that is on a different major network than the subnetted address of the route. Because RIPv1 is a classful routing protocol, the subnet mask is not included in the routing update. When a router receives a RIPv1 routing update, RIP must determine the subnet mask of that route. If the route belongs to the same major classful network as the update, RIPv1 applies the subnet mask of the receiving interface. If the route belongs to a different major classful network than the receiving interface, RIPv1 applies the default classful mask.

The show ip protocols command can be used to display information for any routing protocol enabled on the router. Regarding RIP, this command displays timer information, status of automatic summarization, which networks are enabled on this router for RIP, and other information.

Because RIPv1 is a classful routing protocol, it does not support discontiguous networks or VLSM. Both of these topics are discussed in Chapter 7, "RIPv2".


5.7.1 - Summary and Review
In this chapter, you have learned to:
- Describe the functions, characteristics, and operation of the RIP v1 protocol.
- Configure a device for using RIP v1.
- Verify proper RIP v1 operation.
- Describe how RIP v1 performs automatic summarization.
- Configure, verify, and troubleshoot default routes propagated in a routed network implementing RIP v1.
- Use recommended techniques to solve problems related to RIP v1.


Page 2:


5.7.1 - Summary and Review
This is a review and is not a quiz. Questions and answers are provided.
Question 1. What are the key characteristics of RIP v1?
Answer:
- RIP is a distance vector routing protocol.
- RIP uses hop count as its only metric for path selection.
- Advertised routes with hop counts greater than 15 are unreachable.
- Messages are broadcast every 30 seconds.

Question 2. Refer to the following topology description to answer this and subsequent questions.

Network Topology:
There are four routers in a RIP v1 network, HQ, BR1, BR2, and BR3. The HQ router is connected to each of the branch routers. The HQ router is connected to an ISP router in the Internet cloud.

HQ S0/0/0 is connected to ISP S0/0/0 via a WAN, network 209.165.201.0/30.
HQ S0/0/1 is connected to BR1 S0/0/0 via a WAN, network 192.168.0.0/30.
HQ S0/1/0 is connected to BR2 S0/0/0 via a WAN, network 192.168.0.4/30.
HQ S0/1/1 is connected to BR3 S0/0/0 via a WAN, network 192.168.0.8/30.
BR1 FA0/0 is connected to a LAN, network 192.168.1.0/24.
BR2 FA0/0 is connected to a LAN, network 192.168.2.128/25.
BR3 FA0/0 is connected to a LAN, network 192.168.3.64/26.

HQ has connections to three branch routers (BR1, BR2, and BR3) and to the Internet through an ISP. RIP v1 is configured between HQ and the branch routers. List the commands used to configure RIP v1 routing on the BR1 router.

Answer:
- BR1(config)#router rip
- BR1(config-router)#network 192.168.0.0
- BR1(config-router)#network 192.168.1.0

Question 3. List in order the three commands used to verify and troubleshoot a RIP configuration.
Answer:
- show i p route
- show i p protocols
- debug i p rip

Question 4. Refer to the Question 2 network topology to answer this question. What is the purpose of the passive-interface command? What is the configuration for BR1, including the router prompt for this command?
Answer:
The passive-interface command stops RIP updates from being sent out an interface where RIP updates are not needed. For example, a LAN interface would only need to send out RIP updates if there is another RIP-enabled device on the LAN.

BR1(config-router)#passive-interface FA0/0

Question 5. In RIP v1, what is a boundary router?
Answer: Any router with interfaces in more than one major classful network.

Question 6. Why would you not want to configure a dynamic routing protocol to exchange updates with your ISP?
Answer: ISP routers have routes to all other destinations on the Internet. Because the ISP is the default router for all traffic for which you do not have routes, the best solution is to configure a default route pointing to the ISP. The alternative is to exchange routing updates, have your routers build huge routing tables, and end up sending externally bound traffic to the ISP anyway.

Question 7. Refer to the Question 2 network topology to answer this question. What is the full routing configuration for HQ including RIP v1, default routing, and propagating the default route to the branch routers?
Answer:
HQ(config)#router rip
HQ(config-router)#network 192.168.0.0
HQ(config-router)#default-information originate
HQ(config-router)#exit
HQ(config)#i p router 0.0.0.0 0.0.0.0 s0/0/0

Question 8. Refer to the Question 2 network topology to answer this question. This network is not fully converged. Using only the output from show i p route, determine the problem and either suggest a solution or suggest the next step in determining the source of the problem.

The show i p route output for the routers is as follows:

HQ:
192.168.0.0/30 is subnetted, 3 subnets
C 192.168.0.0 is directly connected, Serial0/0/1
C 192.168.0.4 is directly connected, Serial0/1/0
C 192.168.0.8 is directly connected, Serial0/1/1
R 192.168.1.0/24 [120/1] via 192.168.0.2, 00:00:04, Serial0/0/1
R 192.168.2.0/24 [120/1] via 192.168.0.6, 00:00:22, Serial0/1/0
209.165.201.0/30 is subnetted, 1 subnets
C 209.165.201.0 is directly connected, Serial0/0/0
S* 0.0.0.0/0 is directly connected, Serial0/0/0

BR1:
192.168.0.0/30 is subnetted, 3 subnets
C 192.168.0.0 is directly connected, Serial0/0/0
R 192.168.0.4 [120/1] via 192.168.0.1, 00:00:05, Serial0/0/0
R 192.168.0.8 [120/1] via 192.168.0.1, 00:00:05, Serial0/0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
R 192.168.2.0/24 [120/1] via 192.168.0.1, 00:00:05, Serial0/0/0
R* 0.0.0.0/0 [120/1] via 192.168.0.1, 00:00:05, Serial0/0/0

BR2:
192.168.0.0/30 is subnetted, 3 subnets
R 192.168.0.0 [120/1] via 192.168.0.5, 00:00:06, Serial0/0/0
C 192.168.0.4 is directly connected, Serial0/0/0
R 192.168.0.8 [120/1] via 192.168.0.5, 00:00:06, Serial0/0/0
R 192.168.1.0/24 [120/2] via 192.168.0.5, 00:00:01, Serial0/0/0
192.168.2.0/25 is subnetted, 1 subnets
C 192.168.2.128 is directly connected, FastEthernet0/0
R* 0.0.0.0/0 [120/1] via 192.168.0.5, 00:00:06, Serial0/0/0

BR3:
192.168.0.0/30 is subnetted, 3 subnets
R 192.168.0.0 [120/1] via 192.168.0.9, 00:00:08, Serial0/0/0
R 192.168.0.4 [120/1] via 192.168.0.9, 00:00:08, Serial0/0/0
C 192.168.0.8 is directly connected, Serial0/0/0
R 192.168.1.0/24 [120/2] via 192.168.0.9, 00:00:02, Serial0/0/0
R 192.168.2.0/24 [120/2] via 192.168.0.9, 00:00:08, Serial0/0/0
R* 0.0.0.0/0 [120/1] via 192.168.0.9, 00:00:08, Serial0/0/0


Answer: The LAN for R3 is not being advertised in RIP updates. Because this LAN is also missing from the routing table for R3, the interface is not active. Activating the interface is the first step to solving the convergence problem. As long as R3 is configured to advertise 192.168.3.0 in RIP updates, convergence should be achieved.

Question 9. Refer to the Question 2 network topology to answer this challenge question. What static route command on the ISP summarizes all the networks (and only those networks) accessible through HQ?
Answer: ISP(config)#i p route 192.168.0.0 255.255.252.0 s0/0/0


Page 3:
The Packet Tracer Skills Integration Challenge Activity for this chapter integrates all the knowledge and skills you acquired in the first two chapters of this course and adds knowledge and skills related to RIPv1.

In this activity, you build a network from the ground up. Starting with an addressing space and network requirements, you must implement a network design that satisfies the specifications. Next, you implement an effective RIPv1 routing configuration with integrated default routing. Detailed instructions are provided within the activity.

Packet Tracer Skills Integration Instructions (PDF)

Click the Packet Tracer icon for more details.


5.7.1 - Summary and Review
Link to Packet Tracer Exploration: Chapter 3 - Packet Tracer Skills Integration Challenge

The Packet Tracer Skills Integration Challenge Activity for this chapter integrates all the knowledge and skills you acquired in the first two chapters of this course and adds knowledge and skills related to RIP v1.

In this activity, you build a network from the ground up. Starting with an addressing space and network requirements, you must implement a network design that satisfies the specifications. Next, you implement an effective RIP v1 routing configuration with integrated default routing. Detailed instructions are provided in the activity.


Page 4:
To Learn More

RFCs (Request for Comments) are a series of documents submitted to the IETF (Internet Engineering Task Force) to propose an Internet standard or convey new concepts, information or even occasionally even humor. RFC 1058 is the original RFC for RIP written by Charles Hedrick.

RFCs can be accessed from several web sites including www.ietf.org. Read all or parts of RFC 1058. Much of this information will now be familiar to you, along with some additional information as well.


5.7.1 - Summary and Review
The diagram depicts a collage of people using computers and networks.


5.8 Quiz

5.8.1 Chapter Quiz

Page 1:


5.8.1 - Chapter Quiz
1. Which statement is true about the debug i p rip command?
A. It searches through the running configuration and shows possible errors in the RIP configuration.
B. It displays RIP routing updates as they are sent and received.
C. It automatically identifies routing loops.
D. It shows the history of RIP updates over the previous 90 seconds.

2. What problem does the passive-interface command help resolve?
A. prevents confusion if both RIP v1 and RIP v2 are being advertised on a network
B. prevents wasted bandwidth and processing from unnecessary updates
C. prevents routing loops
D. prevents updates from being sent out without a password

3. What makes a router a boundary router in RIP?
A. if it is on the edge of an autonomous system
B. if a router has multiple interfaces in more than one major classful network
C. if it runs both RIP and EIGRP at the same time
D. if it is configured to be a boundary router by an administrator

4. What command is used with RIP to propagate default routes to neighbors?
A. network 0.0.0.0
B. i p summary-address rip address mask
C. i p default-network address
D. default-information originate

5. What command will create a candidate default route on a RIP router?
A. default-information originate
B. i p default-network 0.0.0.0
C. i p default-gateway 192.168.0.1
D. i p route 0.0.0.0 0.0.0.0 serial0/0/0

6. Refer to the following topology description to answer the question.
Topology description:
There are four routers, A, B, D, and E.
Router A is connected to Router B with a WAN address of 192.168.9.0/30.
Router A is connected to Router D with a WAN address of 192.168.11.12/30.
Router B is connected to Router E with a WAN address of 192.168.10.4/30.
Router D is connected to Router E with a WAN address of 192.168.8.0/30.

Router A has a LAN 10.16.1.0/27 attached to its FA0/0 interface.
Router E has a LAN 10.16.1.64/27 attached to its FA0/0 interface.

All routers are running RIP v1. The interfaces on all routers are up and stable. Users on the 10.16.1.0 network cannot access services on the 10.16.1.64 network. What is the cause of this problem?
A. The RIP hold-down timer in Router A is not allowing the 10.16.1.64 network into routing updates.
B. The network uses variable length subnet masking, and RIP v1 does not allow for this.
C. The 10.16.0.x subnets are discontiguous with each other.
D. Routers A and B need to have their interface configured as passive interfaces.

7. How does a router running RIP v1 determine the subnet mask of the routes that are received in routing updates?
A. The subnet mask is included in the routing update.
B. The router sends a request for the subnet mask to the sending router.
C. The router uses the subnet mask of the local interface of the default subnet mask for the address class in the routing update.
D. The router calculates the subnet mask based on the variable length subnetting in its own configuration.
E. The router defaults to 255.255.255.0 for all updates.

8. Refer to the following routing table output. What is the administrative distance of the route to the 192.168.5.0 network?

output omitted
C 192.168.4.0/24 is directly connected, Serial0/0/1
R 192.168.5.0/24 [120/1] via 192.168.4.1, 00:00:012, Serial0/0/1
R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:024, Serial0/0/0
C 192.168.2.0/24 is directly connected, Serial0/0/0
output omitted

A. 0
B. 1
C. 12
D. 24
E. 120

9. What is the purpose of the network command when RIP is being configured as the routing protocol?
A. It identifies the networks connected to the neighboring router.
B. It restrict networks from being used for static routes.
C. It identifies the destination networks that the router is allowed to install in its routing table.
D. It identifies the directly connected networks that will be included in the RIP routing updates.

10. To ensure proper routing in a network, the network administrator should always check the router configuration to verify that appropriate routes are available. The commands listed will allow the network administrator to view the router configuration for the information needed. Match each command to its result.

Commands:
debug i p rip
show i p protocols
show running-config
show i p route
show interfaces

Results:
Displays current configuration information for configured routing protocols and interfaces.
Checks to see that the interfaces are up and operational.
Displays the network advertised in the updates as the updates are sent and received.
Verifies that the routing protocol is running and advertising the correct networks.
Verifies that routes received are installed in the routing table.

0 comments:

Post a Comment